manaplus-1.7.3.18.ebuild 3.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. [[ ${PV} == 9999 ]] && inherit autotools git-r3
  5. DESCRIPTION="OpenSource 2D MMORPG client for Evol Online and The Mana World"
  6. HOMEPAGE="http://manaplus.evolonline.org"
  7. if [[ ${PV} == 9999 ]] ; then
  8. EGIT_REPO_URI="https://github.com/ManaPlus/ManaPlus.git"
  9. else
  10. SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/${P}.tar.xz"
  11. KEYWORDS="amd64 x86"
  12. fi
  13. LICENSE="GPL-2+"
  14. SLOT="0"
  15. IUSE="mumble nls opengl pugixml +sdl2 test"
  16. RDEPEND="
  17. >=dev-games/physfs-1.0.0
  18. media-fonts/dejavu
  19. media-fonts/liberation-fonts
  20. media-fonts/mplus-outline-fonts
  21. media-fonts/wqy-microhei
  22. media-libs/libpng:0=
  23. net-misc/curl
  24. sys-libs/zlib
  25. x11-apps/xmessage
  26. x11-libs/libX11
  27. x11-misc/xdg-utils
  28. mumble? ( media-sound/mumble )
  29. nls? ( virtual/libintl )
  30. opengl? ( virtual/opengl )
  31. pugixml? ( dev-libs/pugixml )
  32. !pugixml? ( dev-libs/libxml2 )
  33. sdl2? (
  34. media-libs/libsdl2[X,opengl?,video]
  35. media-libs/sdl2-gfx
  36. media-libs/sdl2-image[png]
  37. media-libs/sdl2-mixer[vorbis]
  38. media-libs/sdl2-net
  39. media-libs/sdl2-ttf
  40. )
  41. !sdl2? (
  42. media-libs/libsdl[X,opengl?,video]
  43. media-libs/sdl-gfx
  44. media-libs/sdl-image[png]
  45. media-libs/sdl-mixer[vorbis]
  46. media-libs/sdl-net
  47. media-libs/sdl-ttf
  48. )"
  49. DEPEND="${RDEPEND}
  50. virtual/pkgconfig
  51. nls? ( sys-devel/gettext )"
  52. src_prepare() {
  53. default
  54. if [[ ${PV} == 9999 ]] ; then
  55. eautoreconf
  56. fi
  57. }
  58. src_configure() {
  59. CONFIG_SHELL=/bin/bash \
  60. econf \
  61. --localedir=/usr/share/locale \
  62. --without-internalsdlgfx \
  63. $(use_with mumble) \
  64. $(use_enable nls) \
  65. $(use_with opengl) \
  66. --enable-libxml=$(usex pugixml pugixml libxml) \
  67. $(use_with sdl2) \
  68. $(use_enable test unittests)
  69. }
  70. src_install() {
  71. default
  72. local destpath="/usr/share/${PN}"
  73. dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${destpath}"/data/fonts/dejavusans-bold.ttf
  74. dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${destpath}"/data/fonts/dejavusans.ttf
  75. dosym /usr/share/fonts/dejavu/DejaVuSansMono-Bold.ttf "${destpath}"/data/fonts/dejavusansmono-bold.ttf
  76. dosym /usr/share/fonts/dejavu/DejaVuSansMono.ttf "${destpath}"/data/fonts/dejavusansmono.ttf
  77. dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed-Bold.ttf "${destpath}"/data/fonts/dejavuserifcondensed-bold.ttf
  78. dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed.ttf "${destpath}"/data/fonts/dejavuserifcondensed.ttf
  79. dosym /usr/share/fonts/liberation-fonts/LiberationMono-Bold.ttf "${destpath}"/data/fonts/liberationsansmono-bold.ttf
  80. dosym /usr/share/fonts/liberation-fonts/LiberationMono-Regular.ttf "${destpath}"/data/fonts/liberationsansmono.ttf
  81. dosym /usr/share/fonts/liberation-fonts/LiberationSans-Bold.ttf "${destpath}"/data/fonts/liberationsans-bold.ttf
  82. dosym /usr/share/fonts/liberation-fonts/LiberationSans-Regular.ttf "${destpath}"/data/fonts/liberationsans.ttf
  83. dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-bold.ttf "${destpath}"/data/fonts/mplus-1p-bold.ttf
  84. dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-regular.ttf "${destpath}"/data/fonts/mplus-1p-regular.ttf
  85. dosym /usr/share/fonts/wqy-microhei/wqy-microhei.ttc "${destpath}"/data/fonts/wqy-microhei.ttf
  86. }
  87. src_test() {
  88. make check
  89. }