bf1942-lnxded-1.61.ebuild 964 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils unpacker games
  5. DESCRIPTION="dedicated server for Battlefield 1942"
  6. HOMEPAGE="http://www.battlefield.com/battlefield-1942"
  7. SRC_URI="http://ftp.games.skynet.be/pub/misc/${PN/-/_}-1.6-rc2.run
  8. http://ftp.games.skynet.be/pub/misc/bf1942-update-${PV}.tar.gz"
  9. LICENSE="bf1942-lnxded"
  10. SLOT="0"
  11. KEYWORDS="x86"
  12. IUSE=""
  13. RESTRICT="mirror bindist strip"
  14. S=${WORKDIR}
  15. dir=${GAMES_PREFIX_OPT}/bf1942
  16. Ddir=${D}/${dir}
  17. QA_PREBUILT="${dir}/*.so ${dir}/bf1942_lnxded.*"
  18. src_unpack() {
  19. mkdir bf1942 && cd bf1942
  20. unpack_makeself ${PN/-/_}-1.6-rc2.run
  21. cd ..
  22. unpack bf1942-update-${PV}.tar.gz
  23. }
  24. src_install() {
  25. dodir "${dir}"
  26. mv -f "${S}"/bf1942/* "${S}" || die
  27. rm -rf "${S}"/bf1942 || die
  28. mv "${S}"/* "${Ddir}" || die
  29. dosym bf1942_lnxded.dynamic "${dir}"/bf1942_lnxded
  30. games_make_wrapper ${PN} ./bf1942_lnxded "${dir}"
  31. prepgamesdirs
  32. }