gnome-shell-extensions-3.22.2.ebuild 2.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit gnome2 readme.gentoo-r1
  5. DESCRIPTION="JavaScript extensions for GNOME Shell"
  6. HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShell/Extensions"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. IUSE="examples"
  10. KEYWORDS="amd64 x86"
  11. COMMON_DEPEND="
  12. >=dev-libs/glib-2.26:2
  13. >=gnome-base/libgtop-2.28.3[introspection]
  14. >=app-eselect/eselect-gnome-shell-extensions-20111211
  15. "
  16. RDEPEND="${COMMON_DEPEND}
  17. >=dev-libs/gjs-1.29
  18. dev-libs/gobject-introspection:=
  19. dev-libs/atk[introspection]
  20. gnome-base/gnome-menus:3[introspection]
  21. >=gnome-base/gnome-shell-3.14.2
  22. media-libs/clutter:1.0[introspection]
  23. net-libs/telepathy-glib[introspection]
  24. x11-libs/gdk-pixbuf:2[introspection]
  25. x11-libs/gtk+:3[introspection]
  26. x11-libs/pango[introspection]
  27. x11-themes/adwaita-icon-theme
  28. x11-wm/mutter[introspection]
  29. "
  30. DEPEND="${COMMON_DEPEND}
  31. >=sys-devel/gettext-0.19.6
  32. virtual/pkgconfig
  33. "
  34. # eautoreconf needs gnome-base/gnome-common
  35. DISABLE_AUTOFORMATTING="yes"
  36. DOC_CONTENTS="Installed extensions installed are initially disabled by default.
  37. To change the system default and enable some extensions, you can use
  38. # eselect gnome-shell-extensions
  39. Alternatively, to enable/disable extensions on a per-user basis,
  40. you can use the https://extensions.gnome.org/ web interface, the
  41. gnome-extra/gnome-tweak-tool GUI, or modify the org.gnome.shell
  42. enabled-extensions gsettings key from the command line or a script."
  43. src_configure() {
  44. gnome2_src_configure --enable-extensions=all
  45. }
  46. src_install() {
  47. gnome2_src_install
  48. local example="example@gnome-shell-extensions.gcampax.github.com"
  49. if use examples; then
  50. mv "${ED}usr/share/gnome-shell/extensions/${example}" \
  51. "${ED}usr/share/doc/${PF}/" || die
  52. else
  53. rm -r "${ED}usr/share/gnome-shell/extensions/${example}" || die
  54. fi
  55. readme.gentoo_create_doc
  56. }
  57. pkg_postinst() {
  58. gnome2_pkg_postinst
  59. ebegin "Updating list of installed extensions"
  60. eselect gnome-shell-extensions update
  61. eend $?
  62. readme.gentoo_print_elog
  63. }