zeitgeist-datasources-0.8.1.ebuild 2.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_AUTORECONF=true
  5. VALA_MIN_API_VERSION=0.14
  6. PYTHON_COMPAT=( python2_7 )
  7. inherit autotools-utils eutils mono-env multilib python-single-r1 versionator vala
  8. DIR_PV=$(get_version_component_range 1-2)
  9. DIR_PV2=$(get_version_component_range 1-3)
  10. DESCRIPTION="Plugins whose work is to push activities as events into Zeitgeist daemon"
  11. HOMEPAGE="https://launchpad.net/zeitgeist-datasources/ http://zeitgeist-project.com/"
  12. SRC_URI="https://launchpad.net/zeitgeist-datasources/${DIR_PV}/${DIR_PV2}/+download/${P}.tar.gz"
  13. SLOT="0"
  14. KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
  15. LICENSE="GPL-3"
  16. PLUGINS_IUSE="bzr chromium emacs firefox geany mono telepathy thunderbird tomboy vim"
  17. PLUGINS="bzr chrome emacs firefox geany monodevelop telepathy thunderbird tomboy vim"
  18. IUSE="${PLUGINS_IUSE} static-libs"
  19. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  20. RDEPEND="
  21. ${PYTHON_DEPS}
  22. dev-libs/libzeitgeist
  23. x11-libs/gtk+:2
  24. emacs? ( virtual/emacs )
  25. firefox? ( || ( >=www-client/firefox-4.0 >=www-client/firefox-bin-4.0 ) )
  26. geany? ( dev-util/geany )
  27. mono? ( dev-util/monodevelop )
  28. telepathy? (
  29. net-libs/telepathy-glib[${PYTHON_USEDEP}]
  30. dev-python/dbus-python[${PYTHON_USEDEP}]
  31. dev-python/pygobject[${PYTHON_USEDEP}]
  32. )
  33. tomboy? (
  34. app-misc/tomboy
  35. dev-dotnet/gtk-sharp
  36. dev-dotnet/mono-addins
  37. dev-dotnet/zeitgeist-sharp
  38. dev-python/dbus-python[${PYTHON_USEDEP}]
  39. )
  40. vim? ( app-editors/vim[python] )
  41. "
  42. DEPEND="${RDEPEND}
  43. $(vala_depend)"
  44. PDEPEND="gnome-extra/zeitgeist"
  45. src_prepare() {
  46. rm bzr/bzr-icon-64.png || die
  47. sed \
  48. -e '/bzr-icon-64.png/d' \
  49. -i bzr/Makefile.am || die
  50. sed \
  51. -e '/^allowed_plugin/s:^:#:g' \
  52. -i configure.ac || die
  53. SEARCH='$(datadir)/opt/google/chrome/resources'
  54. REPLACE="/usr/$(get_libdir)/chromium-browser/resources"
  55. sed \
  56. -e "s:${SEARCH}:${REPLACE}:" \
  57. -i chrome/Makefile.* || die
  58. sed \
  59. -e "/^extensiondir/s:= .*:= \$(libdir)/firefox/extensions:g" \
  60. -e "/^xul_extdir/s:xul-ext-zeitgeist:xpcom-firefox@zeitgeist-project.com:g" \
  61. -i firefox/extension/Makefile.am || die
  62. sed \
  63. -e "/^extensiondir/s:= .*:= \$(libdir)/thunderbird/extensions:g" \
  64. -e "/^xul_extdir/s:xul-ext-zeitgeist:thunderbird@zeitgeist-project.com:g" \
  65. -i thunderbird/extension/Makefile.am || die
  66. sed \
  67. -e 's:vim72:vimfiles:' \
  68. -i vim/Makefile.* || die
  69. vala_src_prepare
  70. autotools-utils_src_prepare
  71. }
  72. src_configure() {
  73. local i myplugins
  74. for i in ${PLUGINS}; do
  75. case ${i} in
  76. chrome )
  77. use chromium && myplugins+=( ${i} )
  78. ;;
  79. monodevelop )
  80. use mono && myplugins+=( ${i} )
  81. ;;
  82. * )
  83. use ${i} && myplugins+=( ${i} )
  84. ;;
  85. esac
  86. done
  87. local myeconfargs=(
  88. allowed_plugins="${myplugins[@]}"
  89. )
  90. autotools-utils_src_configure
  91. }