kpackage-5.29.1.ebuild 684 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit kde5
  5. DESCRIPTION="Framework to install and load packages of non binary content"
  6. LICENSE="LGPL-2+"
  7. KEYWORDS="amd64 ~arm x86"
  8. IUSE="man"
  9. RDEPEND="
  10. $(add_frameworks_dep karchive)
  11. $(add_frameworks_dep kconfig)
  12. $(add_frameworks_dep kcoreaddons)
  13. $(add_frameworks_dep ki18n)
  14. "
  15. DEPEND="${RDEPEND}
  16. man? ( $(add_frameworks_dep kdoctools) )
  17. "
  18. src_configure() {
  19. local mycmakeargs=(
  20. $(cmake-utils_use_find_package man KF5DocTools)
  21. )
  22. kde5_src_configure
  23. }
  24. src_test() {
  25. # tests cannot be run in parallel #606942
  26. local myctestargs=(
  27. -j1
  28. )
  29. kde5_src_test
  30. }