oxygen-fonts-5.4.3.ebuild 748 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. KDE_AUTODEPS="false"
  5. KDE_DEBUG="false"
  6. inherit kde5 font xdg-utils
  7. DESCRIPTION="Desktop/GUI font family for integrated use with the KDE Plasma desktop"
  8. HOMEPAGE="https://projects.kde.org/projects/kde/workspace/oxygen-fonts"
  9. LICENSE="OFL-1.1"
  10. KEYWORDS="amd64 ~arm x86"
  11. IUSE=""
  12. DEPEND="
  13. $(add_frameworks_dep extra-cmake-modules)
  14. $(add_qt_dep qtcore)
  15. media-gfx/fontforge
  16. "
  17. RDEPEND="!media-fonts/oxygen-fonts"
  18. DOCS=( README.md )
  19. src_configure() {
  20. xdg_environment_reset
  21. local mycmakeargs=(
  22. -DOXYGEN_FONT_INSTALL_DIR="${FONTDIR}"
  23. )
  24. cmake-utils_src_configure
  25. }
  26. src_install() {
  27. cmake-utils_src_install
  28. font_src_install
  29. }