mate-applets-1.16.0.ebuild 2.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit mate python-single-r1
  6. if [[ ${PV} != 9999 ]]; then
  7. KEYWORDS="~amd64 ~arm ~x86"
  8. fi
  9. DESCRIPTION="Applets for the MATE Desktop and Panel"
  10. LICENSE="GPL-2 FDL-1.1 LGPL-2"
  11. SLOT="0"
  12. IUSE="X gtk3 ipv6 policykit +upower"
  13. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  14. #cpupower #593470
  15. COMMON_DEPEND="${PYTHON_DEPS}
  16. dev-libs/atk:0
  17. >=dev-libs/dbus-glib-0.74:0
  18. >=dev-libs/glib-2.36:2
  19. >=dev-libs/libmateweather-1.6.1[gtk3(-)=]
  20. >=dev-libs/libxml2-2.5:2
  21. dev-python/pygobject:3
  22. >=gnome-base/libgtop-2.11.92:2=
  23. >=mate-base/mate-panel-1.7[gtk3(-)=]
  24. >=net-wireless/wireless-tools-28_pre9:0
  25. >=sys-apps/dbus-1.1.2:0
  26. <sys-power/cpupower-4.7
  27. x11-libs/gdk-pixbuf:2
  28. >=x11-libs/libnotify-0.7:0
  29. x11-libs/libX11:0
  30. x11-libs/pango:0
  31. virtual/libintl:0
  32. !gtk3? (
  33. >=gnome-extra/gucharmap-2.32.1:0
  34. >=x11-libs/gtk+-2.24:2
  35. x11-libs/gtksourceview:2.0
  36. >=x11-libs/libwnck-2.30:1
  37. )
  38. gtk3? (
  39. >=gnome-extra/gucharmap-3.0:2.90
  40. >=x11-libs/gtk+-3.0:3
  41. x11-libs/gtksourceview:3.0
  42. >=x11-libs/libwnck-3.0:3
  43. )
  44. policykit? ( >=sys-auth/polkit-0.97:0 )
  45. upower? (
  46. || (
  47. >=sys-power/upower-0.9.23
  48. >=sys-power/upower-pm-utils-0.9.23
  49. )
  50. )
  51. !!net-analyzer/mate-netspeed"
  52. RDEPEND="${COMMON_DEPEND}
  53. >=mate-base/mate-settings-daemon-1.6"
  54. DEPEND="${COMMON_DEPEND}
  55. app-text/docbook-xml-dtd:4.3
  56. app-text/rarian:0
  57. >=app-text/scrollkeeper-dtd-1:1.0
  58. app-text/yelp-tools:0
  59. >=dev-util/intltool-0.50.1:*
  60. dev-libs/libxslt:0
  61. sys-devel/gettext:*
  62. virtual/pkgconfig:*"
  63. PATCHES=( "${FILESDIR}/${PN}-1.14.1-revert-upstream-cpupower-4.7-fix.patch" )
  64. src_configure() {
  65. mate_src_configure \
  66. --libexecdir=/usr/libexec/mate-applets \
  67. --with-cpufreq-lib=cpupower \
  68. --with-gtk=$(usex gtk3 3.0 2.0) \
  69. $(use_with X x) \
  70. $(use_with upower) \
  71. $(use_enable ipv6) \
  72. $(use_enable policykit polkit)
  73. }
  74. src_test() {
  75. unset DBUS_SESSION_BUS_ADDRESS
  76. emake check
  77. }
  78. src_install() {
  79. python_fix_shebang invest-applet
  80. mate_src_install
  81. local APPLETS="accessx-status battstat charpick command cpufreq drivemount
  82. geyes invest-applet mateweather multiload netspeed stickynotes
  83. timerapplet trashapplet"
  84. for applet in ${APPLETS}; do
  85. docinto ${applet}
  86. for d in AUTHORS ChangeLog NEWS README README.themes TODO; do
  87. [ -s ${applet}/${d} ] && dodoc ${applet}/${d}
  88. done
  89. done
  90. }