aquafont-2.7-r4.ebuild 881 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit font
  4. MY_P="${PN/font/}${PV/\./_}"
  5. DESCRIPTION="Handwritten Japanese fixed-width TrueType font"
  6. HOMEPAGE="http://www.geocities.jp/teardrops_in_aquablue/"
  7. SRC_URI="http://www.geocities.jp/teardrops_in_aquablue/fnt/${MY_P}.zip"
  8. LICENSE="aquafont"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
  11. IUSE="X"
  12. S="${WORKDIR}/${MY_P}"
  13. FONT_S="${S}"
  14. FONT_SUFFIX="ttf"
  15. DEPEND="app-arch/unzip"
  16. RDEPEND=""
  17. DOCS="readme.txt"
  18. # Only installs fonts
  19. RESTRICT="strip binchecks"
  20. FONT_CONF=( "${FILESDIR}/60-aquafont.conf" )
  21. pkg_postinst() {
  22. font_pkg_postinst
  23. echo
  24. elog "To use aquafont instead of the default font for monospace use:"
  25. elog " eselect fontconfig enable 60-aquafont.conf"
  26. echo
  27. }