ftgl-2.1.3_rc5.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils flag-o-matic autotools
  5. MY_PV=${PV/_/-}
  6. MY_PV2=${PV/_/\~}
  7. MY_P=${PN}-${MY_PV}
  8. MY_P2=${PN}-${MY_PV2}
  9. DESCRIPTION="library to use arbitrary fonts in OpenGL applications"
  10. HOMEPAGE="http://ftgl.sourceforge.net/"
  11. SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
  12. LICENSE="MIT"
  13. SLOT="0"
  14. KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
  15. IUSE="static-libs"
  16. DEPEND=">=media-libs/freetype-2.0.9
  17. virtual/opengl
  18. virtual/glu
  19. media-libs/freeglut"
  20. RDEPEND=${DEPEND}
  21. S=${WORKDIR}/${MY_P2}
  22. src_prepare() {
  23. epatch \
  24. "${FILESDIR}"/${P}-gentoo.patch \
  25. "${FILESDIR}"/${P}-underlink.patch
  26. sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
  27. eautoreconf
  28. }
  29. src_configure() {
  30. strip-flags # ftgl is sensitive - bug #112820
  31. econf $(use_enable static-libs static)
  32. }
  33. src_install() {
  34. DOCS="AUTHORS BUGS ChangeLog NEWS README TODO docs/projects_using_ftgl.txt" \
  35. default
  36. rm -rf "${D}"/usr/share/doc/ftgl || die
  37. prune_libtool_files
  38. }