gst-rtsp-server-1.8.3.ebuild 1.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils gstreamer
  5. DESCRIPTION="A GStreamer based RTSP server"
  6. HOMEPAGE="https://people.freedesktop.org/~wtay/"
  7. LICENSE="LGPL-2"
  8. KEYWORDS="amd64 x86"
  9. IUSE="examples +introspection static-libs test"
  10. # FIXME: check should depend on USE=test but check is losy
  11. # configure says good and bad are required by macros forces them to be optional
  12. # they are only used in unittests anyway.
  13. RDEPEND="
  14. >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
  15. >=media-libs/gstreamer-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
  16. >=media-libs/gst-plugins-base-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
  17. introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
  18. "
  19. DEPEND="${RDEPEND}
  20. >=dev-libs/check-0.9.2
  21. >=dev-util/gtk-doc-am-1.12
  22. test? (
  23. >=media-libs/gst-plugins-bad-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
  24. >=media-libs/gst-plugins-good-${PV}:${SLOT}[${MULTILIB_USEDEP}]
  25. )
  26. "
  27. # Due to gstreamer src_configure
  28. QA_CONFIGURE_OPTIONS="--enable-nls"
  29. multilib_src_configure() {
  30. # debug: only adds -g to CFLAGS
  31. # docbook: nothing behind that switch
  32. # libcgroup is automagic and only used in examples
  33. gstreamer_multilib_src_configure \
  34. --disable-examples \
  35. --disable-docbook \
  36. --disable-gtk-doc \
  37. $(multilib_native_use_enable introspection) \
  38. $(use_enable static-libs static) \
  39. $(use_enable test tests) \
  40. LIBCGROUP_LIBS= \
  41. LIBCGROUP_FLAGS=
  42. # work-around gtk-doc out-of-source brokedness
  43. if multilib_is_native_abi ; then
  44. ln -s "${S}"/docs/libs/${d}/html docs/libs/${d}/html || die
  45. fi
  46. }
  47. multilib_src_install() {
  48. emake install DESTDIR="${D}"
  49. # Handle broken upstream modifications to defaults of gtk-doc
  50. emake install -C docs/libs DESTDIR="${D}"
  51. prune_libtool_files
  52. }
  53. multilib_src_install_all() {
  54. einstalldocs
  55. if use examples ; then
  56. insinto /usr/share/doc/${PF}/examples
  57. doins "${S}"/examples/*.c
  58. fi
  59. }