libdcp-1.3.4.ebuild 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
  5. PYTHON_REQ_USE="threads(+)"
  6. inherit python-any-r1 waf-utils
  7. DESCRIPTION="create and read Digital Cinema Packages using JPEG2000 and WAV files"
  8. HOMEPAGE="http://carlh.net/libdcp"
  9. SRC_URI="http://carlh.net/downloads/${PN}/${P}.tar.bz2"
  10. LICENSE="GPL-2"
  11. SLOT="1.0"
  12. KEYWORDS="~amd64"
  13. IUSE="test"
  14. RDEPEND="dev-cpp/glibmm:2
  15. dev-cpp/libxmlpp:2.6
  16. >=dev-libs/boost-1.61.0
  17. <dev-libs/libcxml-0.15.4
  18. dev-libs/libsigc++:2
  19. dev-libs/libxml2
  20. dev-libs/openssl:0
  21. dev-libs/xmlsec
  22. media-libs/libasdcp-cth
  23. media-libs/openjpeg:0
  24. || ( media-gfx/graphicsmagick media-gfx/imagemagick )"
  25. DEPEND="${RDEPEND}
  26. dev-util/waf
  27. virtual/pkgconfig
  28. test? ( app-text/xmldiff )"
  29. PATCHES=( "${FILESDIR}"/${PN}-1.3.3-no-ldconfig.patch
  30. "${FILESDIR}"/${PN}-1.3.4-respect-cxxflags.patch )
  31. src_prepare() {
  32. rm -v waf || die
  33. export WAF_BINARY=${EROOT}usr/bin/waf
  34. ewarn "Some tests failing due missing files/certs are disabled."
  35. sed -e '/atmos_test.cc/d' \
  36. -e '/certificates_test.cc/d' \
  37. -e '/dcp_test.cc/d' \
  38. -e '/decryption_test.cc/d' \
  39. -e '/read_smpte_subtitle_test.cc/d' \
  40. -e '/sound_frame_test.cc/d' \
  41. -i test/wscript || die
  42. default
  43. }
  44. src_test() {
  45. ./build/test/tests || die
  46. }