1234567891011121314151617181920212223242526272829303132333435 |
- # Copyright 1999-2016 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=6
- DESCRIPTION="A library for interfacing Music Player Daemon (media-sound/mpd)"
- HOMEPAGE="https://www.musicpd.org"
- SRC_URI="https://www.musicpd.org/download/${PN}/${PV%.*}/${P}.tar.xz"
- LICENSE="BSD"
- SLOT="0"
- KEYWORDS="amd64 arm hppa ppc ppc64 sparc x86"
- IUSE="doc examples static-libs"
- RDEPEND=""
- DEPEND="doc? ( app-doc/doxygen )"
- src_prepare() {
- default
- sed -e "s:@top_srcdir@:.:" -i doc/doxygen.conf.in
- }
- src_configure() {
- econf \
- $(use_enable static-libs static) \
- $(use_enable doc documentation)
- }
- src_install() {
- default
- use examples && dodoc src/example.c
- use doc || rm -rf "${ED}"/usr/share/doc/${PF}/html
- find "${ED}" -name "*.la" -exec rm -rf {} + || die "failed to delete .la files"
- }
|