libmpdclient-2.9.ebuild 825 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="A library for interfacing Music Player Daemon (media-sound/mpd)"
  5. HOMEPAGE="https://www.musicpd.org"
  6. SRC_URI="https://www.musicpd.org/download/${PN}/${PV%.*}/${P}.tar.xz"
  7. LICENSE="BSD"
  8. SLOT="0"
  9. KEYWORDS="amd64 arm hppa ppc ppc64 sparc x86"
  10. IUSE="doc examples static-libs"
  11. RDEPEND=""
  12. DEPEND="doc? ( app-doc/doxygen )"
  13. src_prepare() {
  14. default
  15. sed -e "s:@top_srcdir@:.:" -i doc/doxygen.conf.in
  16. }
  17. src_configure() {
  18. econf \
  19. $(use_enable static-libs static) \
  20. $(use_enable doc documentation)
  21. }
  22. src_install() {
  23. default
  24. use examples && dodoc src/example.c
  25. use doc || rm -rf "${ED}"/usr/share/doc/${PF}/html
  26. find "${ED}" -name "*.la" -exec rm -rf {} + || die "failed to delete .la files"
  27. }