libmygpo-qt-1.0.7.ebuild 662 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit cmake-utils
  5. DESCRIPTION="Qt/C++ library wrapping the gpodder.net webservice"
  6. HOMEPAGE="http://wiki.gpodder.org/wiki/Libmygpo-qt"
  7. if [[ ${PV} == *9999* ]]; then
  8. EGIT_REPO_URI="https://github.com/gpodder/libmygpo-qt.git"
  9. KEYWORDS=""
  10. SRC_URI=""
  11. inherit git-2
  12. else
  13. KEYWORDS="amd64 x86"
  14. SRC_URI="https://github.com/gpodder/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  15. fi
  16. LICENSE="LGPL-2.1"
  17. SLOT="0"
  18. IUSE=""
  19. RDEPEND="dev-qt/qtcore:4
  20. >=dev-libs/qjson-0.5"
  21. DEPEND="${RDEPEND}
  22. dev-qt/qttest:4
  23. virtual/pkgconfig"
  24. DOCS=( AUTHORS README )