libpgf-6.12.27.ebuild 696 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools
  5. DESCRIPTION="Library to load, handle and manipulate images in the PGF format"
  6. HOMEPAGE="http://www.libpgf.org/"
  7. SRC_URI="https://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.bz2"
  8. LICENSE="LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~ppc x86"
  11. IUSE="doc static-libs"
  12. RDEPEND=""
  13. DEPEND="doc? ( app-doc/doxygen )
  14. app-arch/unzip"
  15. src_prepare() {
  16. if ! use doc; then
  17. sed -i -e "/HAS_DOXYGEN/{N;N;d}" Makefile.am || die
  18. fi
  19. eautoreconf
  20. }
  21. src_configure() {
  22. econf $(use_enable static-libs static)
  23. }
  24. src_install() {
  25. default
  26. find "${ED}" -name '*.la' -delete || die
  27. }