libsixel-1.7.2.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit bash-completion-r1
  5. DESCRIPTION="A lightweight, fast implementation of DEC SIXEL graphics codec"
  6. HOMEPAGE="https://github.com/saitoha/libsixel"
  7. SRC_URI="https://github.com/saitoha/libsixel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MIT public-domain"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ia64 ~x86"
  11. IUSE="curl gd gtk jpeg png"
  12. RDEPEND="curl? ( net-misc/curl )
  13. gd? ( media-libs/gd )
  14. gtk? ( x11-libs/gdk-pixbuf:2 )
  15. jpeg? ( virtual/jpeg:0 )
  16. png? ( media-libs/libpng:0 )"
  17. DEPEND="${RDEPEND}
  18. virtual/pkgconfig"
  19. src_configure() {
  20. econf \
  21. $(use_with curl libcurl) \
  22. $(use_with gd) \
  23. $(use_with gtk gdk-pixbuf2) \
  24. $(use_with jpeg) \
  25. $(use_with png) \
  26. --disable-python \
  27. --with-bashcompletiondir=$(get_bashcompdir)
  28. }
  29. src_test() {
  30. emake test
  31. }
  32. src_install() {
  33. default
  34. cd images
  35. docompress -x /usr/share/doc/${PF}/images
  36. docinto images
  37. dodoc egret.jpg map{8,16}.png snake.jpg vimperator3.png
  38. }