libsoundtouch-1.9.2.ebuild 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils flag-o-matic multilib-minimal
  5. MY_PN=${PN/lib}
  6. DESCRIPTION="Audio processing library for changing tempo, pitch and playback rates"
  7. HOMEPAGE="http://www.surina.net/soundtouch/"
  8. SRC_URI="http://www.surina.net/soundtouch/${P/lib}.tar.gz"
  9. LICENSE="LGPL-2.1"
  10. # subslot = libSoundTouch.so soname
  11. SLOT="0/1"
  12. KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
  13. IUSE="cpu_flags_x86_sse openmp static-libs"
  14. DEPEND=">=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
  15. S=${WORKDIR}/${MY_PN}
  16. src_prepare() {
  17. use openmp && { tc-has-openmp || die "Please switch to an openmp compatible compiler"; }
  18. sed -i "s:^\(dist_doc_DATA=\)COPYING.TXT :\1:" Makefile.am || die
  19. sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:g' configure.ac || die
  20. eautoreconf
  21. }
  22. multilib_src_configure() {
  23. ECONF_SOURCE=${S} \
  24. econf \
  25. --enable-shared \
  26. --disable-integer-samples \
  27. $(use_enable cpu_flags_x86_sse x86-optimizations) \
  28. $(use_enable openmp) \
  29. $(use_enable static-libs static)
  30. }
  31. multilib_src_compile() {
  32. emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
  33. }
  34. multilib_src_install() {
  35. emake DESTDIR="${D}" pkgdocdir="${EPREFIX}"/usr/share/doc/${PF}/html install
  36. }
  37. multilib_src_install_all() {
  38. prune_libtool_files
  39. }