silgraphite-2.3.1.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils
  5. DESCRIPTION="Rendering engine for complex non-Roman writing systems"
  6. HOMEPAGE="http://graphite.sil.org/"
  7. SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.gz"
  8. LICENSE="|| ( CPL-0.5 LGPL-2.1 )"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
  11. IUSE="pango static-libs truetype xft"
  12. RDEPEND="
  13. pango? ( x11-libs/pango media-libs/fontconfig )
  14. truetype? ( media-libs/freetype:2 )
  15. xft? ( x11-libs/libXft )"
  16. DEPEND="${RDEPEND}
  17. virtual/pkgconfig"
  18. src_prepare() {
  19. epatch "${FILESDIR}/${P}-aligned_access.patch"
  20. # Drop DEPRECATED flags, bug #385533
  21. sed -i -e 's:-D[A-Z_]*DISABLE_DEPRECATED:$(NULL):g' \
  22. wrappers/pangographite/Makefile.am wrappers/pangographite/Makefile.in \
  23. wrappers/pangographite/graphite/Makefile.am || die
  24. }
  25. src_configure() {
  26. econf \
  27. $(use_enable static-libs static) \
  28. $(use_with xft) \
  29. $(use_with truetype freetype) \
  30. $(use_with pango pangographite)
  31. }
  32. src_install() {
  33. default
  34. find "${ED}" -name '*.la' -exec rm -f {} +
  35. }