virglrenderer-0.2.0.ebuild 979 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit autotools eutils
  5. if [[ ${PV} == "9999" ]] ; then
  6. EGIT_REPO_URI="git://people.freedesktop.org/~airlied/virglrenderer"
  7. inherit git-2
  8. else
  9. SRC_URI="mirror://gentoo/${P}.tar.xz"
  10. KEYWORDS="amd64 x86"
  11. fi
  12. DESCRIPTION="library used implement a virtual 3D GPU used by qemu"
  13. HOMEPAGE="https://virgil3d.github.io/"
  14. LICENSE="MIT"
  15. SLOT="0"
  16. IUSE="static-libs test"
  17. RDEPEND=">=x11-libs/libdrm-2.4.50
  18. media-libs/libepoxy"
  19. # We need autoconf-archive for @CODE_COVERAGE_RULES@. #568624
  20. DEPEND="${RDEPEND}
  21. sys-devel/autoconf-archive
  22. >=x11-misc/util-macros-1.8
  23. test? ( >=dev-libs/check-0.9.4 )"
  24. src_prepare() {
  25. epatch "${FILESDIR}"/${P}-libdrm.patch #571124
  26. [[ -e configure ]] || eautoreconf
  27. }
  28. src_configure() {
  29. econf \
  30. $(use_enable static-libs static) \
  31. $(use_enable test tests)
  32. }
  33. src_install() {
  34. default
  35. find "${ED}"/usr -name 'lib*.la' -delete
  36. }