grilo-plugins-0.2.12.ebuild 2.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. GCONF_DEBUG="no" # --enable-debug only changes CFLAGS
  5. GNOME2_LA_PUNT="yes"
  6. inherit gnome2
  7. DESCRIPTION="A framework for easy media discovery and browsing"
  8. HOMEPAGE="https://wiki.gnome.org/Projects/Grilo"
  9. LICENSE="LGPL-2.1+"
  10. SLOT="0.2"
  11. KEYWORDS="~arm ~ia64"
  12. IUSE="daap +dvd flickr freebox gnome-online-accounts lua pocket tracker upnp-av +vimeo +youtube"
  13. RDEPEND="
  14. >=dev-libs/glib-2.34:2
  15. >=media-libs/grilo-0.2.10:${SLOT}[network,playlist]
  16. >=media-libs/libmediaart-0.1:1.0
  17. dev-libs/gmime:2.6
  18. dev-libs/json-glib
  19. dev-libs/libxml2:2
  20. dev-db/sqlite:3
  21. daap? ( >=net-libs/libdmapsharing-2.9.12:3.0 )
  22. dvd? ( >=dev-libs/totem-pl-parser-3.4.1 )
  23. flickr? ( net-libs/liboauth )
  24. freebox? ( net-dns/avahi )
  25. gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.7.1 )
  26. lua? ( >=dev-lang/lua-5.2 )
  27. pocket? (
  28. dev-libs/json-glib
  29. >=net-libs/gnome-online-accounts-3.11.4
  30. >=net-libs/rest-0.7
  31. >=dev-libs/totem-pl-parser-3.4.1 )
  32. tracker? ( >=app-misc/tracker-0.10.5:= )
  33. youtube? (
  34. >=dev-libs/libgdata-0.9.1
  35. dev-libs/totem-pl-parser )
  36. upnp-av? (
  37. net-libs/gssdp
  38. >=net-libs/gupnp-0.13
  39. >=net-libs/gupnp-av-0.5 )
  40. vimeo? (
  41. dev-libs/libgcrypt:0
  42. dev-libs/totem-pl-parser )
  43. "
  44. DEPEND="${RDEPEND}
  45. app-text/docbook-xml-dtd:4.5
  46. app-text/yelp-tools
  47. >=dev-util/intltool-0.40.0
  48. virtual/pkgconfig
  49. "
  50. src_configure() {
  51. # --enable-debug only changes CFLAGS, useless for us
  52. # Plugins
  53. # shoutcast seems to be broken
  54. gnome2_src_configure \
  55. --disable-static \
  56. --disable-debug \
  57. --disable-uninstalled \
  58. --enable-bliptv \
  59. --enable-apple-trailers \
  60. --enable-bookmarks \
  61. --enable-filesystem \
  62. --enable-gravatar \
  63. --enable-jamendo \
  64. --enable-lastfm-albumart \
  65. --enable-localmetadata \
  66. --enable-magnatune \
  67. --enable-metadata-store \
  68. --enable-podcasts \
  69. --enable-raitv \
  70. --disable-shoutcast \
  71. --enable-tmdb \
  72. $(use_enable daap dmap) \
  73. $(use_enable dvd optical-media) \
  74. $(use_enable flickr) \
  75. $(use_enable freebox) \
  76. $(use_enable gnome-online-accounts goa) \
  77. $(use_enable lua lua-factory) \
  78. $(use_enable pocket) \
  79. $(use_enable tracker) \
  80. $(use_enable upnp-av upnp) \
  81. $(use_enable vimeo) \
  82. $(use_enable youtube)
  83. }