1234567891011121314151617181920212223242526272829303132333435 |
- # Copyright 1999-2011 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI="2"
- inherit multilib toolchain-funcs
- MY_P=${P/rev/REV}
- DESCRIPTION="REV LADSPA plugins package. A stereo reverb plugin based on the well-known greverb"
- HOMEPAGE="http://www.kokkinizita.net/linuxaudio/"
- SRC_URI="http://www.kokkinizita.net/linuxaudio/downloads/${MY_P}.tar.bz2"
- LICENSE="GPL-2"
- SLOT="0"
- KEYWORDS="amd64 x86"
- IUSE=""
- DEPEND="media-libs/ladspa-sdk"
- RDEPEND="${DEPEND}"
- S=${WORKDIR}/${MY_P}
- src_configure() {
- tc-export CXX
- sed -i Makefile -e 's/-O2//' -e 's/g++/$(CXX) $(LDFLAGS)/' || die "sed Makefile"
- }
- src_install() {
- dodoc AUTHORS README
- insinto /usr/$(get_libdir)/ladspa
- insopts -m0755
- doins *.so
- }
|