vdr-imonlcd-0.0.5-r1.ebuild 860 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit linux-info vdr-plugin-2 udev
  5. DESCRIPTION="VDR Plugin: shows information about the current state of VDR on iMON LCD"
  6. HOMEPAGE="http://projects.vdr-developer.org/wiki/plg-imonlcd"
  7. SRC_URI="mirror://vdr-developerorg/408/${P}.tgz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="nls"
  12. RDEPEND="media-libs/freetype"
  13. DEPEND="${RDEPEND}
  14. nls? ( sys-devel/gettext )"
  15. CONFIG_CHECK="~IR_IMON"
  16. pkg_setup() {
  17. linux-info_pkg_setup
  18. vdr-plugin-2_pkg_setup
  19. }
  20. src_prepare() {
  21. vdr-plugin-2_src_prepare
  22. if ! use nls; then
  23. sed -i -e 's/\(all: libvdr-$(PLUGIN).so\) i18n/\1/' Makefile || die
  24. fi
  25. }
  26. src_install() {
  27. rm -f README.git
  28. vdr-plugin-2_src_install
  29. insinto $(get_udevdir)/rules.d
  30. doins "${FILESDIR}"/99-imonlcd.rules || die
  31. }