vdr-imonlcd-1.0.1.ebuild 756 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit vdr-plugin-2 linux-info udev
  5. VERSION="1327" # every bump, new version
  6. DESCRIPTION="VDR Plugin: shows information about the current state of VDR on iMON LCD"
  7. HOMEPAGE="http://projects.vdr-developer.org/wiki/plg-imonlcd"
  8. SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tgz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE=""
  13. RDEPEND="media-libs/freetype"
  14. DEPEND="${RDEPEND}
  15. media-video/vdr"
  16. CONFIG_CHECK="~IR_IMON"
  17. pkg_setup() {
  18. linux-info_pkg_setup
  19. vdr-plugin-2_pkg_setup
  20. }
  21. src_install() {
  22. rm -f README.git
  23. vdr-plugin-2_src_install
  24. insinto $(get_udevdir)/rules.d
  25. doins "${FILESDIR}"/99-imonlcd.rules || die
  26. }