vdr-radio-0.9.1.ebuild 867 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit vdr-plugin-2
  5. DESCRIPTION="VDR plugin: show background image for radio and decode RDS Text"
  6. HOMEPAGE="http://www.vdr-portal.de/board/thread.php?threadid=58795"
  7. SRC_URI="http://www.egal-vdr.de/plugins/${P}.tgz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. RDEPEND=">=media-video/vdr-1.7.34"
  13. DEPEND="${RDEPEND}"
  14. VDR_RCADDON_FILE="${FILESDIR}/rc-addon.sh-0.2.0"
  15. src_install() {
  16. vdr-plugin-2_src_install
  17. cd "${S}"/config
  18. insinto /usr/share/vdr/radio
  19. doins mpegstill/rtext*
  20. dosym rtextOben-kleo2-live.mpg /usr/share/vdr/radio/radio.mpg
  21. dosym rtextOben-kleo2-replay.mpg /usr/share/vdr/radio/replay.mpg
  22. exeinto /usr/share/vdr/radio
  23. doexe scripts/radioinfo*
  24. diropts -m 755 -o vdr -g vdr
  25. keepdir "/var/cache/vdr-radio"
  26. }