bashnapi-1.1.5.ebuild 737 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. SUB_VER=0.15
  5. MY_TAR=napi_v${PV}_subotage_${SUB_VER}
  6. DESCRIPTION="Napiprojekt.pl subtitle downloader in bash"
  7. HOMEPAGE="https://sourceforge.net/projects/bashnapi/"
  8. SRC_URI="mirror://sourceforge/${PN}/${MY_TAR}.tgz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE=""
  13. S=${WORKDIR}/napi
  14. src_install() {
  15. default # for docs
  16. dobin napi.sh
  17. }
  18. pkg_postinst() {
  19. elog "Optional runtime dependencies:"
  20. elog
  21. elog " \033[1mmedia-video/subotage\033[0m for subtitle format conversion"
  22. elog
  23. elog " \033[1mmedia-video/mediainfo\033[0m"
  24. elog "or \033[1mmedia-video/mplayer\033[0m for FPS detection (for conversion)"
  25. }