guvcview-2.0.4.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils flag-o-matic qmake-utils
  5. MY_P=${PN}-src-${PV}
  6. DESCRIPTION="GTK+ UVC Viewer"
  7. HOMEPAGE="http://guvcview.sourceforge.net/"
  8. SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="gsl libav pulseaudio qt5"
  13. RDEPEND=">=dev-libs/glib-2.10
  14. media-libs/libpng:0=
  15. media-libs/libsdl2
  16. media-libs/libv4l
  17. >=media-libs/portaudio-19_pre
  18. !libav? ( >=media-video/ffmpeg-2.8:0= )
  19. libav? ( media-video/libav:= )
  20. virtual/ffmpeg
  21. virtual/libusb:1
  22. virtual/udev
  23. pulseaudio? ( >=media-sound/pulseaudio-0.9.15 )
  24. gsl? ( >=sci-libs/gsl-1.15 )
  25. qt5? ( dev-qt/qtwidgets:5 )
  26. !qt5? ( >=x11-libs/gtk+-3.6:3 )
  27. !<sys-kernel/linux-headers-3.4-r2" #448260
  28. DEPEND="${RDEPEND}
  29. dev-util/intltool
  30. sys-devel/gettext
  31. virtual/os-headers
  32. sys-devel/autoconf-archive
  33. virtual/pkgconfig"
  34. S=${WORKDIR}/${MY_P}
  35. src_prepare() {
  36. epatch "${FILESDIR}/ffmpeg3.patch"
  37. sed -i '/^docdir/,/^$/d' Makefile.am || die
  38. eautoreconf
  39. }
  40. src_configure() {
  41. export MOC="$(qt5_get_bindir)/moc"
  42. use qt5 && append-cxxflags -std=c++11
  43. econf \
  44. --disable-debian-menu \
  45. $(use_enable gsl) \
  46. $(use_enable pulseaudio pulse) \
  47. $(use_enable qt5) \
  48. $(use_enable !qt5 gtk3)
  49. }