guvcview-2.0.5.ebuild 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils flag-o-matic qmake-utils toolchain-funcs
  5. MY_P=${PN}-src-${PV}
  6. DESCRIPTION="GTK+ UVC Viewer"
  7. HOMEPAGE="http://guvcview.sourceforge.net/"
  8. SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="gsl libav pulseaudio qt5"
  13. RDEPEND=">=dev-libs/glib-2.10
  14. media-libs/libpng:0=
  15. media-libs/libsdl2
  16. media-libs/libv4l
  17. >=media-libs/portaudio-19_pre
  18. !libav? ( >=media-video/ffmpeg-2.8:0= )
  19. libav? ( media-video/libav:= )
  20. virtual/ffmpeg
  21. virtual/libusb:1
  22. virtual/udev
  23. pulseaudio? ( >=media-sound/pulseaudio-0.9.15 )
  24. gsl? ( >=sci-libs/gsl-1.15 )
  25. qt5? ( dev-qt/qtwidgets:5 )
  26. !qt5? ( >=x11-libs/gtk+-3.6:3 )
  27. !<sys-kernel/linux-headers-3.4-r2" #448260
  28. DEPEND="${RDEPEND}
  29. dev-util/intltool
  30. sys-devel/gettext
  31. virtual/os-headers
  32. sys-devel/autoconf-archive
  33. virtual/pkgconfig"
  34. S=${WORKDIR}/${MY_P}
  35. src_prepare() {
  36. sed -i '/^docdir/,/^$/d' Makefile.am || die
  37. eautoreconf
  38. }
  39. src_configure() {
  40. export MOC="$(qt5_get_bindir)/moc"
  41. use qt5 && append-cxxflags -std=c++11
  42. # 599030
  43. tc-export CC CXX
  44. econf \
  45. --disable-debian-menu \
  46. $(use_enable gsl) \
  47. $(use_enable pulseaudio pulse) \
  48. $(use_enable qt5) \
  49. $(use_enable !qt5 gtk3)
  50. }