mkclean-0.8.7.ebuild 849 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. DESCRIPTION="mkclean is a command line tool to clean and optimize Matroska files"
  5. HOMEPAGE="http://www.matroska.org/downloads/mkclean.html"
  6. SRC_URI="http://downloads.sourceforge.net/project/matroska/${PN}/${P}.tar.bz2"
  7. LICENSE="BSD"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. IUSE=""
  11. src_configure() {
  12. # non-standard configure
  13. ./configure || die
  14. # fixing generated makefiles
  15. sed -i -e 's|^\(LFLAGS.*+=.*\$(LIBS)\)|\1 \$(LDFLAGS)|g' \
  16. -e 's|^\(STRIP.*=\)|\1 echo|g' $(find -name "*.mak") || die
  17. }
  18. src_compile() {
  19. emake -f GNUmakefile -j1
  20. emake -C mkclean -f mkWDclean.mak -j1
  21. emake -C mkclean/regression -f mkcleanreg.mak -j1
  22. }
  23. src_install() {
  24. dobin release/*/mk*clean*
  25. newdoc ChangeLog.txt ChangeLog
  26. newdoc ReadMe.txt README
  27. }