sguil-client-0.8.0.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit multilib
  5. MY_PV="${PV/_p/p}"
  6. DESCRIPTION="GUI Console for sguil Network Security Monitoring"
  7. HOMEPAGE="http://sguil.sf.net"
  8. SRC_URI="mirror://sourceforge/sguil/sguil-client-${MY_PV}.tar.gz"
  9. LICENSE="QPL"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="ssl"
  13. RDEPEND="
  14. >=dev-lang/tcl-8.3:0=[-threads]
  15. >=dev-lang/tk-8.3:0=
  16. >=dev-tcltk/itcl-3.2
  17. >=dev-tcltk/tclx-8.3
  18. dev-tcltk/itk
  19. dev-tcltk/iwidgets
  20. dev-tcltk/tcllib
  21. net-analyzer/wireshark
  22. ssl? ( >=dev-tcltk/tls-1.4.1 )
  23. "
  24. S=${WORKDIR}/sguil-${MY_PV}
  25. src_prepare() {
  26. sed -i \
  27. -e "/^set SGUILLIB /s:./lib:/usr/$(get_libdir)/sguil:" \
  28. -e '/^set ETHEREAL_PATH /s:/usr/sbin/ethereal:/usr/bin/wireshark:' \
  29. -e '/^set SERVERHOST /s:demo.sguil.net:localhost:' \
  30. -e '/^set MAILSERVER /s:mail.example.com:localhost:' \
  31. -e '/^set GPG_PATH /s:/usr/local/bin/gpg:/usr/bin/gpg:' \
  32. client/sguil.conf || die
  33. }
  34. src_install() {
  35. dobin client/sguil.tk
  36. insinto /etc/sguil
  37. doins client/sguil.conf
  38. insinto "/usr/$(get_libdir)/sguil"
  39. doins -r "${S}"/client/lib/*
  40. dodoc doc/*
  41. }