pdns-ldap-backend-0.2.ebuild 850 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils multilib
  5. DESCRIPTION="Fork of the official but unmaintained LDAP backend"
  6. HOMEPAGE="http://repo.or.cz/w/pdns-ldap-backend.git http://sequanux.org/cgi-bin/mailman/listinfo/pdns-ldap-backend"
  7. SRC_URI="http://sequanux.org/dl/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS=""
  11. IUSE="sasl"
  12. DEPEND=">=net-dns/pdns-3.2[-ldap]
  13. net-nds/openldap[sasl=]
  14. virtual/krb5"
  15. RDEPEND="${DEPEND}"
  16. src_prepare() {
  17. eautoreconf
  18. }
  19. src_configure() {
  20. econf \
  21. --disable-static \
  22. --with-pdns="${EPREFIX}/usr/include" \
  23. --libdir=/usr/$(get_libdir)/powerdns
  24. }
  25. src_install() {
  26. DOCS="AUTHORS ChangeLog NEWS README USAGE* src/dns.ldif"
  27. default
  28. prune_libtool_files --all
  29. insinto /etc/openldap/schema
  30. doins schema/*
  31. }