ncftp-3.2.6.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools eutils toolchain-funcs
  5. DESCRIPTION="An extremely configurable ftp client"
  6. HOMEPAGE="http://www.ncftp.com/"
  7. SRC_URI="
  8. ftp://ftp.${PN}.com/${PN}/${P}-src.tar.xz -> ${P}.tar.xz
  9. "
  10. LICENSE="Clarified-Artistic"
  11. SLOT="0"
  12. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x86-solaris"
  13. IUSE="pch"
  14. DEPEND="
  15. sys-libs/ncurses:*
  16. "
  17. RDEPEND="
  18. ${DEPEND}
  19. "
  20. src_prepare() {
  21. default
  22. tc-export CC
  23. sed -i \
  24. -e "s:CC=gcc:CC ?= ${CC}:" \
  25. -e 's:@SFLAG@::' \
  26. -e 's:@STRIP@:true:' \
  27. Makefile.in */Makefile.in || die
  28. AT_M4DIR=autoconf_local/ eautoreconf
  29. }
  30. src_configure() {
  31. LC_ALL="C" \
  32. LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses)" \
  33. econf \
  34. $(use_enable pch precomp) \
  35. --disable-ccdv \
  36. --disable-universal
  37. }
  38. src_install() {
  39. default
  40. dodoc README.txt doc/*.txt
  41. docinto html
  42. dodoc doc/html/*.html
  43. }