autossh-1.4e.ebuild 571 B

12345678910111213141516171819202122232425
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="Automatically restart SSH sessions and tunnels"
  5. HOMEPAGE="http://www.harding.motd.ca/autossh/"
  6. SRC_URI="http://www.harding.motd.ca/${PN}/${P}.tgz"
  7. LICENSE="BSD"
  8. KEYWORDS="amd64 ~arm ~hppa ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
  9. SLOT="0"
  10. RDEPEND="net-misc/openssh"
  11. src_prepare() {
  12. sed -i -e "s:\$(CC):& \$(LDFLAGS):" Makefile.in || die
  13. }
  14. src_install() {
  15. dobin autossh
  16. dodoc CHANGES README autossh.host rscreen
  17. doman autossh.1
  18. }