fakeidentd-2.6-r1.ebuild 908 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. DESCRIPTION="A static, secure identd. One source file only!"
  6. HOMEPAGE="http://www.guru-group.fi/~too/sw/"
  7. SRC_URI="http://www.guru-group.fi/~too/sw/identd.readme -> ${P}.readme
  8. http://www.guru-group.fi/~too/sw/releases/identd.c -> ${P}.c"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 arm hppa ~ia64 ppc ppc64 ~sh sparc x86"
  12. IUSE=""
  13. echoit() {
  14. echo "$@"
  15. "$@"
  16. }
  17. src_unpack() {
  18. mkdir -p "${S}"
  19. echoit cp "${DISTDIR}"/${P}.{c,readme} "${S}" || die
  20. }
  21. src_compile() {
  22. echoit $(tc-getCC) ${CFLAGS} ${LDFLAGS} \
  23. -DTRG=\"${PN}\" -DUSE_UNIX_OS -DVERSION=\"${PV}\" \
  24. -o ${PN} ${P}.c || die
  25. }
  26. src_install() {
  27. dosbin ${PN}
  28. newdoc ${P}.readme identd.readme
  29. newinitd "${FILESDIR}"/fakeidentd.rc fakeidentd
  30. newconfd "${FILESDIR}"/fakeidentd.confd fakeidentd
  31. }