gns3-gui-1.5.3.1.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python3_4 )
  5. inherit distutils-r1 eutils
  6. DESCRIPTION="Graphical Network Simulator"
  7. HOMEPAGE="http://www.gns3.net/"
  8. SRC_URI="https://github.com/GNS3/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64"
  12. RESTRICT="test"
  13. #net-misc/gns3-server version should always match gns3-gui version
  14. RDEPEND="
  15. >=dev-python/libcloud-0.15.1[${PYTHON_USEDEP}]
  16. >=dev-python/ws4py-0.3.4[${PYTHON_USEDEP}]
  17. >=dev-python/requests-2.6.0[${PYTHON_USEDEP}]
  18. >=dev-python/paramiko-1.15.1[${PYTHON_USEDEP}]
  19. >=dev-python/psutil-3.0.0[${PYTHON_USEDEP}]
  20. >=net-misc/gns3-converter-1.3.0[${PYTHON_USEDEP}]
  21. =net-misc/gns3-server-$PVR[${PYTHON_USEDEP}]
  22. dev-qt/qtgui:5
  23. dev-qt/qtsvg:5
  24. dev-python/PyQt5[gui,network,svg,widgets,${PYTHON_USEDEP}]
  25. "
  26. DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
  27. python_configure() {
  28. # temporary fix until upstream releases 1.4.5 with proper setup.py
  29. sed -i -e 's/gns3-net-converter/gns3-converter/' setup.py requirements.txt || die
  30. }
  31. python_install_all() {
  32. distutils-r1_python_install_all
  33. doicon "${WORKDIR}/${P}/resources/images/gns3.ico"
  34. make_desktop_entry "gns3" "GNS3" "/usr/share/pixmaps/gns3.ico" "Utility"
  35. }