guacamole-server-0.9.9-r1.ebuild 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit systemd user
  5. DESCRIPTION="This is the proxy-daemon used by www-apps/guacamole"
  6. HOMEPAGE="http://guac-dev.org/"
  7. SRC_URI="mirror://sourceforge/guacamole/${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="multilib pulseaudio rdp ssh ssl telnet vnc vorbis"
  12. REQUIRED_USE="multilib? ( ssl )"
  13. RDEPEND="
  14. x11-libs/cairo
  15. media-libs/libpng:0=
  16. virtual/jpeg:0
  17. dev-libs/ossp-uuid
  18. rdp? ( >=net-misc/freerdp-1.1.0_beta1_p20150312:= )
  19. ssh? (
  20. x11-libs/pango
  21. net-libs/libssh2 )
  22. telnet? (
  23. net-libs/libtelnet
  24. x11-libs/pango )
  25. vnc? (
  26. net-libs/libvncserver[threads]
  27. pulseaudio? ( media-sound/pulseaudio ) )
  28. ssl? ( dev-libs/openssl:0= )
  29. vorbis? ( media-libs/libvorbis )
  30. "
  31. DEPEND="${RDEPEND}"
  32. PATCHES=(
  33. # From Fedora for compat with newer freerdp
  34. "${FILESDIR}"/${P}-glyph-order.patch
  35. "${FILESDIR}"/${P}-clipboard-id-update.patch
  36. )
  37. src_configure() {
  38. local myconf="--without-terminal --without-pango"
  39. if use ssh || use telnet; then
  40. myconf="--with-terminal --with-pango"
  41. fi
  42. econf ${myconf} \
  43. $(use_with ssh) \
  44. $(use_with rdp) \
  45. $(use_with vnc) \
  46. $(use_with pulseaudio pulse) \
  47. $(use_with vorbis) \
  48. $(use_with telnet) \
  49. $(use_with ssl)
  50. }
  51. src_install() {
  52. default
  53. doinitd "${FILESDIR}/guacd"
  54. systemd_dounit "${FILESDIR}/guacd.service"
  55. }
  56. pkg_postinst() {
  57. enewgroup guacd
  58. enewuser guacd -1 -1 -1 guacd
  59. }