netctl-1.9.ebuild 1.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit bash-completion-r1 eutils
  5. if [[ ${PV} = *9999* ]]; then
  6. EGIT_REPO_URI="git://projects.archlinux.org/netctl.git"
  7. inherit git-2
  8. DEPEND="app-text/asciidoc"
  9. else
  10. SRC_URI="https://sources.archlinux.org/other/packages/${PN}/${P}.tar.xz"
  11. KEYWORDS="amd64 x86"
  12. fi
  13. DESCRIPTION="Profile based network connection tool from Arch Linux"
  14. HOMEPAGE="https://wiki.archlinux.org/index.php/Netctl
  15. https://www.archlinux.org/packages/core/any/netctl/
  16. https://projects.archlinux.org/netctl.git/"
  17. LICENSE="GPL-3"
  18. SLOT="0"
  19. IUSE=""
  20. DEPEND+="
  21. virtual/pkgconfig
  22. sys-apps/systemd
  23. "
  24. RDEPEND="
  25. >=app-shells/bash-4.0
  26. >=net-dns/openresolv-3.5.4-r1
  27. sys-apps/iproute2
  28. sys-apps/systemd
  29. !<net-misc/dhcpcd-6.4.0
  30. "
  31. src_prepare() {
  32. sed -i -e "s:/usr/bin/ifplugd:/usr/sbin/ifplugd:" \
  33. "services/netctl-ifplugd@.service" || die
  34. }
  35. src_compile() {
  36. return 0
  37. }
  38. src_install() {
  39. emake DESTDIR="${D%/}" SHELL=bash install
  40. dodoc AUTHORS NEWS README
  41. newbashcomp contrib/bash-completion netctl
  42. bashcomp_alias netctl netctl-auto wifi-menu
  43. insinto /usr/share/zsh/site-functions
  44. newins contrib/zsh-completion _netctl
  45. }
  46. pkg_postinst() {
  47. if [[ -z ${REPLACING_VERSIONS} ]]; then
  48. elog "To get additional features, a number of optional runtime dependencies may be"
  49. elog "installed."
  50. optfeature "DHCP support" net-misc/dhcpcd ">=net-misc/dhcp-5.6.7[client]"
  51. optfeature "WPA support" net-wireless/wpa_supplicant
  52. optfeature "interactive assistant" dev-util/dialog
  53. optfeature "automatic connection" sys-apps/ifplugd
  54. optfeature "bonding support" net-misc/ifenslave
  55. optfeature "dialup support" net-dialup/ppp
  56. fi
  57. }