ypbind-1.37.2-r1.ebuild 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit readme.gentoo systemd
  5. MY_P=${PN}-mt-${PV}
  6. S="${WORKDIR}/${MY_P}"
  7. DESCRIPTION="Multithreaded NIS bind service (ypbind-mt)"
  8. HOMEPAGE="http://www.linux-nis.org/nis/ypbind-mt/index.html"
  9. SRC_URI="http://www.linux-nis.org/download/ypbind-mt/${MY_P}.tar.bz2"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86"
  13. IUSE="debug dbus nls slp systemd"
  14. RDEPEND="
  15. debug? ( dev-libs/dmalloc )
  16. dbus? ( dev-libs/dbus-glib )
  17. slp? ( net-libs/openslp )
  18. systemd? (
  19. net-nds/rpcbind
  20. >=net-nds/yp-tools-2.12-r1
  21. sys-apps/systemd )
  22. !systemd? (
  23. net-nds/yp-tools
  24. || ( net-nds/portmap net-nds/rpcbind ) )
  25. "
  26. DEPEND="${RDEPEND}
  27. nls? ( sys-devel/gettext )
  28. "
  29. DOC_CONTENTS="
  30. If you are using dhcpcd, be sure to add the -Y option to
  31. dhcpcd_eth0 (or eth1, etc.) to keep dhcpcd from clobbering
  32. /etc/yp.conf.
  33. "
  34. src_prepare() {
  35. ! use systemd && export ac_cv_header_systemd_sd_daemon_h=no
  36. }
  37. src_configure() {
  38. econf \
  39. $(use_enable nls) \
  40. $(use_enable slp) \
  41. $(use_with debug dmalloc) \
  42. $(use_enable dbus dbus-nm)
  43. }
  44. src_install() {
  45. default
  46. insinto /etc
  47. newins etc/yp.conf yp.conf.example
  48. newconfd "${FILESDIR}/ypbind.confd-r1" ypbind
  49. newinitd "${FILESDIR}/ypbind.initd" ypbind
  50. use systemd && systemd_dounit "${FILESDIR}/ypbind.service"
  51. readme.gentoo_create_doc
  52. }