rssguard-3.3.5.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit qmake-utils
  5. DESCRIPTION="A tiny RSS and Atom feed reader"
  6. HOMEPAGE="https://github.com/martinrotter/rssguard"
  7. SRC_URI="https://github.com/martinrotter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE="debug +webengine"
  12. RDEPEND="
  13. >=dev-qt/qtcore-5.6:5
  14. >=dev-qt/qtgui-5.6:5
  15. >=dev-qt/qtnetwork-5.6:5
  16. >=dev-qt/qtsql-5.6:5
  17. >=dev-qt/qtwidgets-5.6:5
  18. >=dev-qt/qtxml-5.6:5
  19. webengine? ( >=dev-qt/qtwebengine-5.6:5[widgets] )
  20. "
  21. DEPEND="${RDEPEND}
  22. >=dev-qt/linguist-tools-5.6:5
  23. "
  24. PATCHES=( "${FILESDIR}/${P}-deps.patch" )
  25. src_prepare() {
  26. default
  27. # remove bundled qtbase translations
  28. rm localization/qtbase* || die
  29. sed -i -e "s|localization/qtbase-[a-z][a-z].ts||g" ${PN}.pro || die
  30. }
  31. src_configure() {
  32. eqmake5 \
  33. CONFIG+=$(usex debug debug release) \
  34. USE_WEBENGINE=$(usex webengine true false) \
  35. LRELEASE_EXECUTABLE="$(qt5_get_bindir)/lrelease" \
  36. PREFIX="${EPREFIX}"/usr \
  37. INSTALL_ROOT=.
  38. }
  39. src_install() {
  40. emake install INSTALL_ROOT="${D}"
  41. }