qbittorrent-3.3.10.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils
  5. DESCRIPTION="BitTorrent client in C++ and Qt"
  6. HOMEPAGE="http://www.qbittorrent.org/"
  7. if [[ ${PV} == *9999 ]]; then
  8. inherit git-r3
  9. EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
  10. else
  11. MY_P=${P/_}
  12. SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
  13. KEYWORDS="amd64 arm ~ppc64 x86"
  14. S=${WORKDIR}/${MY_P}
  15. fi
  16. LICENSE="GPL-2"
  17. SLOT="0"
  18. IUSE="+dbus debug webui +X"
  19. REQUIRED_USE="dbus? ( X )"
  20. RDEPEND="
  21. >=dev-libs/boost-1.62.0-r1:=
  22. dev-qt/qtconcurrent:5
  23. dev-qt/qtcore:5
  24. dev-qt/qtnetwork:5[ssl]
  25. >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt5,X?]
  26. dev-qt/qtxml:5
  27. >=net-libs/libtorrent-rasterbar-1.0.6
  28. sys-libs/zlib
  29. dbus? ( dev-qt/qtdbus:5 )
  30. X? (
  31. dev-qt/qtgui:5
  32. dev-qt/qtwidgets:5
  33. )"
  34. DEPEND="${RDEPEND}
  35. dev-qt/linguist-tools:5
  36. virtual/pkgconfig"
  37. DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
  38. src_configure() {
  39. mycmakeargs=(
  40. -DQT5=ON
  41. -DSYSTEM_QTSINGLEAPPLICATION=ON
  42. -DDBUS=$(usex dbus)
  43. -DGUI=$(usex X)
  44. -DWEBUI=$(usex webui)
  45. )
  46. cmake-utils_src_configure
  47. }