qbittorrent-3.3.7.ebuild 1.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit flag-o-matic qmake-utils
  5. DESCRIPTION="BitTorrent client in C++ and Qt"
  6. HOMEPAGE="http://www.qbittorrent.org/"
  7. if [[ ${PV} == *9999 ]]; then
  8. inherit git-r3
  9. EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
  10. else
  11. MY_P=${P/_}
  12. SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
  13. KEYWORDS="~amd64 arm ~ppc64 ~x86"
  14. S=${WORKDIR}/${MY_P}
  15. fi
  16. LICENSE="GPL-2"
  17. SLOT="0"
  18. IUSE="+dbus debug +qt5 webui +X"
  19. REQUIRED_USE="
  20. dbus? ( X )
  21. "
  22. RDEPEND="
  23. dev-libs/boost:=
  24. >=net-libs/libtorrent-rasterbar-1.0.6
  25. sys-libs/zlib
  26. !qt5? (
  27. >=dev-libs/qjson-0.8.1[qt4(+)]
  28. dev-qt/qtcore:4[ssl]
  29. >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt4,X?]
  30. dbus? ( dev-qt/qtdbus:4 )
  31. X? ( dev-qt/qtgui:4 )
  32. )
  33. qt5? (
  34. dev-qt/qtconcurrent:5
  35. dev-qt/qtcore:5
  36. dev-qt/qtnetwork:5[ssl]
  37. >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt5,X?]
  38. dev-qt/qtxml:5
  39. dbus? ( dev-qt/qtdbus:5 )
  40. X? (
  41. dev-qt/qtgui:5
  42. dev-qt/qtwidgets:5
  43. )
  44. )
  45. "
  46. DEPEND="${RDEPEND}
  47. qt5? ( dev-qt/linguist-tools:5 )
  48. virtual/pkgconfig
  49. "
  50. DOCS=(AUTHORS Changelog CONTRIBUTING.md README.md TODO)
  51. src_configure() {
  52. # workaround build issue with older boost
  53. # https://github.com/qbittorrent/qBittorrent/issues/4112
  54. if has_version '<dev-libs/boost-1.58'; then
  55. append-cppflags -DBOOST_NO_CXX11_REF_QUALIFIERS
  56. fi
  57. econf \
  58. --with-qjson=system \
  59. --with-qtsingleapplication=system \
  60. $(use_enable dbus qt-dbus) \
  61. $(use_enable debug) \
  62. $(use_enable webui) \
  63. $(use_enable X gui) \
  64. $(use_enable !X systemd) \
  65. $(use_with !qt5 qt4)
  66. if use qt5; then
  67. eqmake5
  68. else
  69. eqmake4
  70. fi
  71. }
  72. src_install() {
  73. emake INSTALL_ROOT="${D}" install
  74. einstalldocs
  75. }