xnap-2.5-r3.ebuild 601 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. DESCRIPTION="A P2P framework and client"
  4. HOMEPAGE="http://xnap.sf.net"
  5. SRC_URI="mirror://sourceforge/xnap/${P}r3.jar"
  6. LICENSE="GPL-2"
  7. SLOT="0"
  8. KEYWORDS="x86"
  9. IUSE=""
  10. RDEPEND=">=virtual/jre-1.3"
  11. S=${WORKDIR}
  12. src_unpack() {
  13. cp ${DISTDIR}/${A} ${WORKDIR}/
  14. }
  15. src_install() {
  16. mv ${S}/${A} ${S}/${PN}.jar
  17. insinto /opt/${PN}/lib
  18. doins ${PN}.jar
  19. echo "#!/bin/sh" > ${PN}
  20. echo "cd /opt/${PN}" >> ${PN}
  21. echo '${JAVA_HOME}'/bin/java -jar lib/${PN}.jar '$*' >> ${PN}
  22. into /opt
  23. dobin ${PN}
  24. }