Math-BigInt-1.999.806.ebuild 815 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DIST_AUTHOR=PJACKLAM
  5. DIST_VERSION=1.999806
  6. DIST_EXAMPLES=("examples/*")
  7. inherit perl-module
  8. DESCRIPTION="Arbitrary size floating point math package"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~ppc-macos ~x86-solaris"
  11. IUSE="test"
  12. RDEPEND="
  13. >=virtual/perl-Math-Complex-1.390.0
  14. "
  15. DEPEND="${RDEPEND}
  16. virtual/perl-ExtUtils-MakeMaker
  17. test? ( >=virtual/perl-Test-Simple-0.940.0 )
  18. "
  19. PDEPEND="
  20. >=virtual/perl-Math-BigInt-FastCalc-0.270.0
  21. >=virtual/perl-bignum-0.220.0
  22. >=virtual/perl-Math-BigRat-0.260.200
  23. "
  24. # where does this come from?
  25. src_test() {
  26. perl_rm_files t/author-*.t t/03podcov.t t/00sig.t t/02pod.t
  27. perl-module_src_test
  28. }