pal-0.9.7.ebuild 769 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils
  5. DESCRIPTION="Positional Astronomy Library"
  6. HOMEPAGE="http://github.com/Starlink/pal"
  7. SRC_URI="https://github.com/Starlink/${PN}/releases/download/v${PV}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  11. IUSE="doc static-libs"
  12. RDEPEND="sci-astronomy/erfa:="
  13. DEPEND="${RDEPEND}"
  14. src_configure() {
  15. econf --without-starlink \
  16. --without-stardocs \
  17. --with-erfa \
  18. $(use_enable static-libs static)
  19. }
  20. src_install() {
  21. default
  22. # remove cruft from non-fhs complient
  23. rm -r "${ED}"usr/share/pal || die
  24. rm -r "${ED}"usr/{docs,manifests,news} || die
  25. use static-libs || prune_libtool_files --all
  26. }