raxml-7.2.6.ebuild 962 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils flag-o-matic toolchain-funcs
  5. DESCRIPTION="Sequential, Parallel & Distributed Inference of Large Phylogenetic Trees"
  6. HOMEPAGE="http://wwwkramer.in.tum.de/exelixis/software.html"
  7. SRC_URI="http://wwwkramer.in.tum.de/exelixis/software/RAxML-${PV}.tar.bz2"
  8. SLOT="0"
  9. LICENSE="GPL-2"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="cpu_flags_x86_sse3 +threads"
  12. REQUIRED_USE="cpu_flags_x86_sse3"
  13. # mpi is not supported in version 7.2.2. mpi is enabled by adding -DPARALLEL to CFLAGS
  14. DEPEND="" # mpi? ( virtual/mpi )"
  15. RDEPEND="${DEPEND}"
  16. S="${WORKDIR}/RAxML-${PV}"
  17. src_prepare() {
  18. epatch "${FILESDIR}"/${P}-makefile.patch
  19. use cpu_flags_x86_sse3 && append-cflags -D__SIM_SSE3
  20. use threads && \
  21. append-cflags -D_USE_PTHREADS && \
  22. append-ldflags -pthread
  23. tc-export CC
  24. }
  25. src_compile() {
  26. emake -f Makefile.gcc
  27. }
  28. src_install() {
  29. dobin raxmlHPC
  30. }