ghemical-3.0.0.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="3"
  4. inherit autotools eutils
  5. DESCRIPTION="Chemical quantum mechanics and molecular mechanics"
  6. HOMEPAGE="http://bioinformatics.org/ghemical/"
  7. SRC_URI="http://bioinformatics.org/ghemical/download/current/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~x86"
  11. IUSE="openbabel seamonkey threads"
  12. RDEPEND="
  13. dev-libs/glib:2
  14. gnome-base/libglade:2.0
  15. sci-chemistry/mpqc
  16. >=sci-libs/libghemical-3.0.0
  17. >=x11-libs/liboglappth-1.0.0
  18. virtual/opengl
  19. x11-libs/pango
  20. x11-libs/gtk+:2
  21. x11-libs/gtkglext
  22. openbabel? ( sci-chemistry/openbabel )"
  23. DEPEND="${RDEPEND}
  24. virtual/pkgconfig"
  25. src_prepare() {
  26. epatch "${FILESDIR}"/2.99.2-docs.patch
  27. eautoreconf
  28. }
  29. src_configure() {
  30. # With amd64, if you want gamess I recommend adding gamess and gtk-gamess to package.provided for now.
  31. # Change the built-in help browser.
  32. if use seamonkey ; then
  33. sed -i -e 's|mozilla|seamonkey|g' src/gtk_app.cpp || die "sed failed for seamonkey!"
  34. else
  35. sed -i -e 's|mozilla|firefox|g' src/gtk_app.cpp || die "sed failed for firefox!"
  36. fi
  37. econf \
  38. $(use_enable openbabel) \
  39. $(use_enable threads)
  40. }
  41. src_install() {
  42. emake DESTDIR="${D}" install || die "install failed"
  43. make_desktop_entry /usr/bin/ghemical Ghemical /usr/share/ghemical/${PV}/pixmaps/ghemical.png
  44. }