mustang-3.2.1.ebuild 1.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils toolchain-funcs
  5. MY_PN="MUSTANG"
  6. SRC_P="${PN}_v${PV}"
  7. MY_P="${MY_PN}_v${PV}"
  8. DESCRIPTION="MUltiple STructural AligNment AlGorithm"
  9. HOMEPAGE="http://www.csse.monash.edu.au/~karun/Site/mustang.html"
  10. SRC_URI="http://www.csse.unimelb.edu.au/~arun/${PN}/${SRC_P}.tgz"
  11. LICENSE="BSD"
  12. SLOT="0"
  13. KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
  14. IUSE=""
  15. S="${WORKDIR}/${MY_P}"
  16. src_prepare() {
  17. epatch "${FILESDIR}"/${P}-gcc-4.7.patch
  18. }
  19. src_compile() {
  20. emake \
  21. CPP=$(tc-getCXX) \
  22. CPPFLAGS="${CXXFLAGS}" \
  23. LDFLAGS="${LDFLAGS}"
  24. }
  25. src_test() {
  26. ./bin/${P} -f ./data/test/test_zf-CCHH || die
  27. }
  28. src_install() {
  29. newbin bin/${P} mustang
  30. doman man/${PN}.1
  31. dodoc README
  32. }
  33. pkg_postinst() {
  34. elog "If you use this program for an academic paper, please cite:"
  35. elog "Arun S. Konagurthu, James C. Whisstock, Peter J. Stuckey, and Arthur M. Lesk"
  36. elog "Proteins: Structure, Function, and Bioinformatics. 64(3):559-574, Aug. 2006"
  37. }