opencpn-plugin-polar-1.1007.ebuild 779 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. WX_GTK_VER="3.0"
  5. MY_PN="polar_pi"
  6. if [[ ${PV} == "9999" ]] ; then
  7. EGIT_REPO_URI="https://github.com/ptulp/${MY_PN}.git"
  8. inherit git-r3 cmake-utils wxwidgets
  9. KEYWORDS=""
  10. else
  11. SRC_URI="
  12. https://github.com/ptulp/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
  13. "
  14. inherit cmake-utils wxwidgets
  15. KEYWORDS="~amd64 ~x86"
  16. S="${WORKDIR}/${MY_PN}-${PV}"
  17. fi
  18. DESCRIPTION="Polar Diagram Plugin for OpenCPN"
  19. HOMEPAGE="https://github.com/ptulp/polar_pi"
  20. LICENSE="GPL-2+"
  21. SLOT="0"
  22. IUSE=""
  23. RDEPEND="
  24. x11-libs/wxGTK:${WX_GTK_VER}
  25. >=sci-geosciences/opencpn-4.2.0
  26. sys-devel/gettext
  27. "
  28. DEPEND="${RDEPEND}"
  29. src_prepare() {
  30. need-wxwidgets unicode
  31. cmake-utils_src_prepare
  32. }