ext3grep-0.10.2.ebuild 817 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils
  5. DESCRIPTION="Recover deleted files on an ext3 file system"
  6. HOMEPAGE="https://code.google.com/p/ext3grep/"
  7. SRC_URI="https://ext3grep.googlecode.com/files/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="debug pch"
  12. DOCS="NEWS README"
  13. RDEPEND=""
  14. DEPEND="sys-fs/e2fsprogs
  15. virtual/os-headers
  16. virtual/pkgconfig"
  17. src_prepare() {
  18. epatch \
  19. "${FILESDIR}"/${PN}-0.10.1-gcc44.patch \
  20. "${FILESDIR}"/${P}-include-unistd_h-for-sysconf.patch
  21. # Fix build against latest e2fsprogs, taken from
  22. # https://code.google.com/p/ext3grep/issues/detail?id=34
  23. epatch "${FILESDIR}"/${P}-new-e2fsprogs.diff
  24. }
  25. src_configure() {
  26. econf \
  27. $(use_enable debug) \
  28. $(use_enable pch)
  29. }