gentoo-sources-3.10.95.ebuild 750 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. ETYPE="sources"
  5. K_WANT_GENPATCHES="base extras experimental"
  6. K_GENPATCHES_VER="100"
  7. K_DEBLOB_AVAILABLE="0"
  8. inherit kernel-2
  9. detect_version
  10. detect_arch
  11. KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
  12. HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
  13. IUSE="experimental"
  14. DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
  15. SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
  16. pkg_postinst() {
  17. kernel-2_pkg_postinst
  18. einfo "For more info on this patchset, and how to report problems, see:"
  19. einfo "${HOMEPAGE}"
  20. }
  21. pkg_postrm() {
  22. kernel-2_pkg_postrm
  23. }