gentoo-sources-4.1.15-r1.ebuild 779 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. ETYPE="sources"
  5. K_WANT_GENPATCHES="base extras experimental"
  6. K_GENPATCHES_VER="20"
  7. K_DEBLOB_AVAILABLE="0"
  8. K_KDBUS_AVAILABLE="0"
  9. inherit kernel-2
  10. detect_version
  11. detect_arch
  12. KEYWORDS="alpha amd64 arm ~arm64 -hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
  13. HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
  14. IUSE="experimental"
  15. DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
  16. SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
  17. pkg_postinst() {
  18. kernel-2_pkg_postinst
  19. einfo "For more info on this patchset, and how to report problems, see:"
  20. einfo "${HOMEPAGE}"
  21. }
  22. pkg_postrm() {
  23. kernel-2_pkg_postrm
  24. }