gentoo-sources-4.4.39.ebuild 734 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. ETYPE="sources"
  5. K_WANT_GENPATCHES="base extras experimental"
  6. K_GENPATCHES_VER="43"
  7. inherit kernel-2
  8. detect_version
  9. detect_arch
  10. KEYWORDS="alpha amd64 ~arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
  11. HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
  12. IUSE="experimental"
  13. DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
  14. SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
  15. pkg_postinst() {
  16. kernel-2_pkg_postinst
  17. einfo "For more info on this patchset, and how to report problems, see:"
  18. einfo "${HOMEPAGE}"
  19. }
  20. pkg_postrm() {
  21. kernel-2_pkg_postrm
  22. }